FaxcomAnywhere Account Portal, Web Client, and Web Service Down
Incident Report for Biscom Cloud
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 12:18 EST
Update
Currently both FaxcomAnywhere Office and Enterprise services remain operating normally. Biscom's IT staff has corrected the issue with page counts in the FaxcomAnywhere customer portal. This issue did not affect transmitting and receiving of faxes.

Biscom's IT staff will continue to monitor the situation and will provide additional updates as they become available.
Posted Feb 12, 2021 - 08:59 EST
Update
Currently both FaxcomAnywhere Office and Enterprise services are operating normally. Biscom's IT staff has noticed an issue with page counts in the FaxcomAnywhere customer portal. This issue is not affecting transmitting and receiving of faxes.

An update will be posted as when it becomes available.
Posted Feb 10, 2021 - 10:21 EST
Monitoring
A fix has been implemented and we are monitoring all services. At this time all functionality is available to all customers. If the status should change another update will be provided.
Posted Feb 09, 2021 - 20:55 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 09, 2021 - 17:06 EST
Update
The restoration process is ongoing. Further updates to follow.
Posted Feb 09, 2021 - 13:04 EST
Update
The restoration process is ongoing. Further updates to follow.
Posted Feb 09, 2021 - 11:01 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 09, 2021 - 11:00 EST
Update
The restoration process is continuing. Further updates to follow.
Posted Feb 09, 2021 - 10:13 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 09, 2021 - 10:12 EST
Identified
Biscom IT staff is in the process of restoring functionality to customers. Currently, FaxcomAnywhere Enterprise customers are able to send and receive faxes without issue. Office customers currently are unable to login to either the web client or web service. Faxcom Office SMTP users are also unable to send faxes. The customer portal is inaccessible to both Enterprise and Office customers.

Further updates will be made as they become available.
Posted Feb 09, 2021 - 09:37 EST
Investigating
Biscom IT personnel are currently investigating a login issue to the FAXCOMAnywhere Account Management Portal, Web Client and Web Service.

Updates will follow as they become available.
Posted Feb 09, 2021 - 07:11 EST
This incident affected: Biscom FAXCOM Anywhere (Biscom FAXCOM Anywhere, Account Management Portal, Web Service, Web Client).