Customer Usage not Up-to-Date
Incident Report for Biscom Cloud
Resolved
The issue has not returned after implementing the fix. Biscom will continue to monitor this issue and if anything changes a new notification will be sent out.
Posted Sep 08, 2023 - 07:53 EDT
Monitoring
A fix has been implemented and we will continue to monitor for any changes.
Posted Sep 07, 2023 - 17:24 EDT
Identified
Biscom has identified the problem and are working to resolve the issue.
Posted Sep 07, 2023 - 14:34 EDT
Investigating
We are investigating an issue where customer's usage is not up to date in the CloudFax Customer Portal. This issue does not affect inbound or outbound faxing. Additional information will be posted once it becomes available.
Posted Sep 07, 2023 - 10:51 EDT
This incident affected: Biscom FAXCOM Anywhere (Account Management Portal).