Inbound local 978 numbers receiving busy signals
Incident Report for Biscom Cloud
Resolved
All issues contributing to the outage have been resolved. No further issues have been experienced since the corrective action was completed at 2am eastern. Biscom IT staff will continue to monitor the situation. If there are any changes a new notification will be sent out.

If you are still experiencing issues with any fax number, in your account, belonging to the 978 area code please contact Biscom Technical Support at 978-250-8355 or support@biscom.com
Posted Oct 22, 2021 - 06:59 EDT
Monitoring
As of 2:05 this morning faxes have been successfully received into the fax servers serviced by this recent outage. Biscom IT staff will continue to monitor the situation.
Posted Oct 22, 2021 - 04:00 EDT
Identified
Biscom IT team has received and update detailing repairs are underway. Currently there is no estimated completion time. The situation is being monitored and additional statuses will be passed along.
Posted Oct 21, 2021 - 22:26 EDT
Investigating
Biscom is currently investigating an issue where customers are receiving busy signals. IT personal is currently engaging with the Telecom provider. Additional information will be provided when it becomes available.
Posted Oct 21, 2021 - 16:49 EDT
This incident affected: Biscom FAXCOM Anywhere (Biscom FAXCOM Anywhere, Telecom).