Intermittent Login Failures with Biscom Web Client (webfax.biscomfax.com)
Incident Report for Biscom Cloud
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 04:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2023 - 15:25 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 16, 2023 - 13:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2023 - 13:13 EDT
Investigating
We are currently investigating an intermittent issue logging into the Biscom Web Fax Client at the following URL: webfax.biscomfax.com. More information will be posted once available.
Posted Aug 16, 2023 - 12:04 EDT
This incident affected: Biscom FAXCOM Anywhere (Web Client).