Biscom Transit Application Connection Issue
Incident Report for Biscom Cloud
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 16:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2024 - 10:55 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 05, 2024 - 10:23 EDT
Investigating
We are currently investigating an issue where connections to Biscom Transit application are timing out.
Posted Sep 05, 2024 - 10:16 EDT
This incident affected: Biscom Transit (Biscom Transit Website).