Service Availability Issue
Incident Report for Biscom Cloud
Resolved
This incident has been resolved.
Posted Apr 05, 2022 - 17:11 EDT
Investigating
We are currently investigating an issue with Biscom Transit application availability. This is impacting all customers ability to access the Biscom Transit web site. Further information will be posted once it is available.
Posted Apr 05, 2022 - 16:34 EDT
This incident affected: Biscom Transit (Biscom Transit Website).