Biscom Transit Outage

Incident Report for Biscom Cloud

Resolved

This issue has been resolved. All systems are now operational
Posted Feb 06, 2025 - 09:46 EST

Investigating

We are currently investigating this issue
Posted Feb 06, 2025 - 09:30 EST
This incident affected: Biscom Transit (Biscom Transit Website).